Chapter 3

Using the Graphical User Interface (GUI) on AT-9900 Series Switches

Introduction ................................................................................................... 3-2
What is the GUI? ........................................................................................... 3-2
Accessing the Switch via the GUI ............................................................... 3-3
  Browser and PC Setup ................................................................. 3-3
  Establishing a Connection to the Switch ........................................ 3-5
  Secure Access ................................................................................. 3-9
  System Status Details ................................................................. 3-10
Using the GUI: Navigation and Features ....................................................... 3-10
  The Configuration Menu ......................................................... 3-10
  Using Configuration Pages ....................................................... 3-11
  The Management Menu .......................................................... 3-13
  The Monitoring Menu .............................................................. 3-14
  The Diagnostics Menu .............................................................. 3-14
  Combining GUI and CLI Configuration ............................................. 3-14
Troubleshooting ........................................................................................... 3-15
  Enabling and Disabling the GUI ......................................................... 3-15
  Deleting Temporary Files ............................................................. 3-15
  Accessing the Switch via the GUI ..................................................... 3-16
Configuring the Switch using the GUI .......................................................... 3-17
  Using the Default IP Address ......................................................... 3-17
  Changing the IP address ............................................................... 3-18
Command Reference ................................................................................... 3-19
  disable gui .................................................................................... 3-19
  enable gui .................................................................................... 3-19
  reset gui ....................................................................................... 3-20
  show gui ....................................................................................... 3-20
Introduction

You can set up, manage, monitor, and troubleshoot the switch using the command line interface (CLI) or the web-based GUI. The GUI includes the commonly-required functions for a number of protocols. You can access the GUI using HTTP, for local or remote access or HTTPS, for secure remote access.

This section describes the basic functionality of the GUI, including:

- What is the GUI?
  - an introduction to the Graphical User Interface
- Accessing the switch via the GUI:
  - browser and PC setup, including interaction with HTTP proxy servers
  - establishing a connection to your switch, including information about configuring SSL for secure access
  - the System Status page, the first GUI page you see
  - diagnosing and solving connection problems
- Using the GUI: navigation and features:
  - an overview of the menus
  - using configuration pages, with a description of key elements of GUI pages
  - combining GUI and CLI configuration

See Chapter 1, Getting Started for information about

- changing your password
- using the context sensitive online help
- saving your configuration

What is the GUI?

The GUI (Graphical User Interface) is a web-based device management tool designed to make it easier to configure and monitor the switch. The GUI provides an alternative to the CLI (Command Line Interface). Its purpose is to make complicated tasks simpler and regularly performed tasks quicker.

The GUI relies on an HTTP server that runs on the switch, and a web browser on the host PC. When you use the GUI to configure the switch, the GUI sends commands to the switch and the switch sends the results back to your browser, all via HTTP.

The tasks you may perform using the GUI are not as comprehensive as the command set available on the CLI, but for some protocols, a few clicks of the mouse are adequate.

The GUI is stored on the switch as an embedded resource file, with the .rsc file extension. Resource files are model-specific, with the model and version encoded in the file name.
**Accessing the Switch via the GUI**

To use the GUI to configure the switch, you use a web browser to open a connection to the switch’s HTTP server. Therefore, you need a PC, a web browser and the switch. Supported browsers and operating systems, and the settings you need on your PC and browser, are detailed in the following section. Switch setup is detailed in “Establishing a Connection to the Switch” on page 3-5.

**Browser and PC Setup**

The GUI requires a web browser installed on a PC. The following table shows supported combinations of operating system and browser.

<table>
<thead>
<tr>
<th></th>
<th>IE 5.0</th>
<th>IE 5.5</th>
<th>IE 6.0</th>
<th>NS 6.2.2</th>
<th>NS 6.2.3</th>
</tr>
</thead>
<tbody>
<tr>
<td>Windows 95</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Windows 98</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Windows ME</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>Windows 2000</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>Windows XP</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
</tr>
</tbody>
</table>

JavaScript must be enabled. To enable JavaScript in Internet Explorer:

1. From the Tools menu, select Internet Options.
2. Select the Security tab.
3. Click the Custom Level button.
4. Under the Scripting section, ensure that “Active scripting” is enabled.

To enable JavaScript in Netscape 6.2.x:

1. From the Edit menu, select Preference.
2. Select the Advanced menu option.
3. Ensure that the “Enable JavaScript for Navigator” checkbox is checked.

The minimum screen resolution on the PC is 800x600.

**Pop-up Windows**

Pop-up windows must be allowed. If you are using a toolbar or plug-in on your browser to block pop-ups, disable it while using the GUI. The GUI displays detailed configuration options and information in pop-up windows.

Either turn the toolbar off or specify that pop-ups are allowed for the IP address of the switch. To turn off a toolbar on Internet Explorer 6, select Toolbars from the View menu and make sure the toolbar is not checked.
HTTP Proxy Servers

An HTTP proxy server provides a security barrier between a private network’s PCs and the Internet. The PCs send HTTP requests (and other web traffic) to the server, which then forwards the requests appropriately. Similarly, the server receives incoming HTTP traffic addressed to a PC on the private network, and forwards it to the appropriate PC. Proxy servers can be used to block traffic from undesirable web sites, to log traffic flows, and to disallow cookies.

If your browser is configured to use a proxy server, and the switch is on your side of the proxy server, you must set the browser to bypass proxy entries for the IP address of the appropriate interface on the switch. See “Establishing a Connection to the Switch” on page 3-5 for information about giving switch interfaces IP addresses.

**Caution** To ensure that your network’s security settings are not compromised, see your network administrator for information about bypassing the proxy server on your system.

To bypass the proxy server on Internet Explorer, if your browser administration does not use a script, and the PC and the switch are in the same subnet:

1. From the Tools menu, select Internet Options.
2. Select the Connections tab and click the LAN Settings button.
3. Check the “Bypass proxy server for local addresses” checkbox.
4. If necessary, click the Advanced button and enter a list of local addresses.

To bypass the proxy server on Netscape, if your browser does not use a script:

1. From the Edit menu, select Preferences.
2. Click the Advanced menu option to expand it.
3. Select the Proxies menu option.
4. Enter the switch’s IP address in the “No Proxy for” list.
Establishing a Connection to the Switch

Before you start, consider how the switch fits into your network. If you are installing a new switch, consider whether you want to configure it before deploying it into the LAN, or want to configure it in situ. If you want to access a switch that has already been configured, consider the relative positions of the PC and the switch. The flow chart below summarises this process, and the procedures that follow take you through each possibility in detail.

Figure 3-1: A summary of the process for establishing a connection via the GUI.
Option 1: Configuring the Switch before Installation

Use this procedure if you want to do any of the following:

- to configure the switch before installing it in your LAN
- to install the switch at a remote office or a customer site and want to configure it first
- to set a dedicated management PC permanently connected to the switch

1. Select a PC to browse to the switch from.
   
   You can browse to the switch from any PC that is running a supported operating system with a supported browser installed. See “Browser and PC Setup” on page 3-3 for more information.
   
   You need to know the subnet of the PC.

2. Connect the PC to the switch.
   
   Use a straight-through Ethernet cable to connect an Ethernet card on the PC to any one of the switch ports.

3. Access the switch’s command line interface.
   
   Access the CLI from the PC, as described in your Installation and Safety Guide or Quick Install Guide.

4. Enable IP.

   ```
   enable ip
   ```

5. Assign the vlan1 interface an IP address in the same subnet as the PC.

   ```
   add ip interface=vlan1 ip=ipaddress mask=mask
   ```

6. Save the configuration and set the switch to use it on bootup.

   ```
   create config=your-name.cfg
   set config=your-name.cfg
   ```

7. On the PC, bypass the HTTP proxy server if necessary.

   See “HTTP Proxy Servers” on page 3-4 for more information.

8. Point your web browser at the LAN interface’s IP address.

9. At the login prompt, enter the user name and password.

   The default username is manager:

   ```
   User Name: manager
   ```
   
   ```
   Password: friend
   ```

   The System Status page is displayed (Figure 3-5 on page 3-10). Select options from the sidebar menu to configure and manage the switch.
Option 2: Installing the Switch into the LAN

Use this procedure if you want to install the switch into the LAN before you configure it.

1. Select a PC to browse to the switch from.
   You can browse to the switch from any PC that is running a supported operating system with a supported browser installed, with JavaScript enabled. See “Browser and PC Setup” on page 3-3 for more information.
   You need to know the PC’s subnet.

2. Plug the switch into the LAN.
   To install the switch into the same subnet as the PC:
   Use an Ethernet cable to connect one of the switch ports to a device on the LAN segment, for example, a hub, router or switch.

   Figure 3-3: Connecting the switch into the same LAN segment as the PC.

   To install the switch into a different subnet than the PC:
   Use an Ethernet cable to connect any one of the switch ports to a device on the LAN segment in which you require the switch to work, for example, a hub, router, or switch.

   Figure 3-4: Configuring the switch from a PC in another subnet

   Important You can browse to the switch through any VLAN, as long as you give that VLAN an IP address (below). These instructions assume you use vlan1. The switch ports all belong to vlan1 by default.

3. Access the switch’s command line interface.
   Access the CLI from the PC, as described in your Installation and Safety Guide or Quick Install Guide.

4. Enable IP.
   ```bash
   enable ip
   ```
5. Assign the vlan1 interface an IP address.
   
   ```
   add ip interface=vlan1 ip=ipaddress mask=mask
   ```
   
   If you use DHCP to assign IP addresses to devices on your LAN, and you want to manage the switch within this DHCP regime, we recommend that you set your DHCP server to always assign the same IP address to the switch. This lets you access the GUI by browsing to that IP address, and also lets you use the switch as a gateway device for your LAN. If you need the switch’s MAC address for this, you can display it with the command `show switch`. To set the interface to obtain its IP address by DHCP, use the commands:
   
   ```
   add ip interface=vlan1 ipaddress=dhcp
   enable ip remoteassign
   ```

6. If the PC you want to browse from is in a different subnet from the switch, give the switch a route to the PC.
   
   ```
   add ip route=pc-subnet interface=vlan1
   nexthop=gateway-ipaddress
   ```
   
   where:
   
   - `PC-subnet` is the IP subnet address of the PC. For example, if the PC has an IP address of 192.168.6.1 and a mask of 255.255.255.0, its subnet address is 192.168.6.0.
   - `gateway-ipaddress` is the IP address of the gateway device that connects the PC’s subnet with the switch’s subnet (Figure 3-4 on page 3-7).

7. If you want to be able to browse to the GUI securely, configure SSL (Secure Sockets Layer).
   
   For a step-by-step example, see “Configuration Example” on page 34-6 of Chapter 34, Secure Sockets Layer (SSL).

8. Save the configuration and set the switch to use it on bootup.
   
   ```
   create config=filename.cfg
   set config=filename.cfg
   ```

9. On the PC, bypass the HTTP proxy server, if necessary.
   
   See “HTTP Proxy Servers” on page 3-4 for more information.

10. Point your web browser at the LAN interface’s IP address.
    For normal access, point your web browser to
    
    ```
    http://ip-address
    ```
    For secure access, point your web browser to
    
    ```
    https://ip-address
    ```
    
    where `ip-address` is the interface’s IP address.
    
    For more information about secure access, see “Configuration Example” on page 34-6 of Chapter 34, Secure Sockets Layer (SSL).

11. At the login prompt, enter the user name and password.
    
    The default username is `manager`:
    
    ```
    User Name: manager
    Password: friend
    ```
    
    The System Status page is displayed (Figure 3-5 on page 3-10). Select options from the sidebar menu to configure and manage the switch.
Option 3: Connecting to an Installed Switch

Use this procedure if at least one interface on the switch already has an IP address, and the switch is already installed in a LAN.

1. Find out the IP address of the switch’s interface.
   - Ask your system administrator. Alternatively, access the CLI, as described in your Installation and Safety Guide or Quick Install Guide, and enter the command:
     ```
     show ip interface
     ```
   - **Important** You can browse to the switch through any VLAN, as long as you give that VLAN an IP address (below). These instructions assume you use vlan1. The switch ports all belong to vlan1 by default.

2. Select a PC.
   - You can browse to the GUI from any PC that:
     - has an IP address in the same subnet as the switch, or that the switch has a route to
     - is running a supported operating system
     - has a supported browser installed, with JavaScript enabled
   - See “Browser and PC Setup” on page 3-3 for more information.

3. If necessary, bypass the HTTP proxy server.
   - See “HTTP Proxy Servers” on page 3-4 for more information.

4. Browse to the switch
   - For normal access, point your web browser to
     ```
     http://ip-address
     ```
   - where `ip-address` is the interface’s IP address.
   - To access the switch securely if SSL (Secure Sockets Layer) has been configured on the interface, point your web browser to
     ```
     https://ip-address
     ```
   - For more information about secure access, see “Configuration Example” on page 34-6 of Chapter 34, Secure Sockets Layer (SSL).

5. At the login prompt, enter the user name and password
   - The default username is manager:
     ```
     User Name: manager
     ```
     ```
     Password: friend
     ```
   - The System Status page is displayed (Figure 3-5 on page 3-10). Select options from the sidebar menu to configure and manage the switch.

Secure Access

You can optionally browse to the switch using Secure Sockets Layer (SSL). This means that sensitive data including passwords and email addresses can not be accessed by malicious parties.

A detailed step-by-step example is in “Configuration Example” on page 34-6 of Chapter 34, Secure Sockets Layer (SSL).
System Status Details

The GUI opens to display the system status. The following figure highlights key information on the page.

Using the GUI: Navigation and Features

The GUI consists of a large number of pages, which you navigate between using the menu on the left of the browser window. This section describes how to use the GUI, and gives an overview of its functionality.

The Configuration Menu

Configuration available through the GUI includes:

- the system identity and mail server
- the system time, or NTP (Network Time Protocol)
- triggers, to automatically run scripts at a time you specify or in response to events you specify
- ping polling, to monitor device reachability and respond to changes in reachability
- SNMP (Simple Network Management Protocol)
- switch port settings, including mirroring, trunking and storm limits
- VLANs, STP, MSTP and GARP
- Internet Protocol: interfaces, static routes, the preferences of dynamic routes, RIP, multicasting, and OSPF
- IPX
Using Configuration Pages

Most protocols are configured by creating or adding an entry - an IP route, a PIM interface, and so on. For such protocols, configuration with the GUI is based on sets of three pages: first you see a “summary” page, and from that you access an “add” page and a “modify” page. Complex protocols are subdivided into different tabs, each with their own summary, add and modify pages.

Only one person can configure a particular switch with the GUI at a time, to avoid clashes between configurations. Monitoring and diagnostics pages can be viewed by more than one user at a time.

Use the menus and buttons on the GUI pages to navigate, not your browser’s buttons, to ensure that the configuration settings are saved correctly.

The summary page displays a selection table of existing items and information about them (for example, existing PIM interfaces in Figure 3-6). Below the selection table is a row of buttons, labelled Add, Modify and Remove.

To add a new item, click the Add button. This opens the popup “add” page, which lets you create a new item (for example, configure a new PIM interface in Figure 3-7 on page 3-12).

To modify an existing item, select it by clicking on the option button at the beginning of its entry in the selection table. Then click the Modify button. This opens the popup “modify” page, which lets you expand or change the configuration (for example, change the Hello interval for a PIM interface in Figure 3-8 on page 3-12).

To delete or destroy an item, select it by clicking on the option button at the beginning of its entry in the selection table. Then click the Remove button.

Figure 3-6: An example of a configuration page with a selection table
Editable Fields

GUI pages allow you to enter values or select options through a range of field types. These include:

- text fields, to enter character strings or numbers, especially for fields where there are few limits on the entries (such as names). See the online help for valid characters and field length.
- select lists, to select one option from a small number of possibilities. Only valid options are listed. For example, if you are asked to select an IP interface from a drop-down list, the only interfaces displayed are those to which you have assigned an IP address.
Using the Graphical User Interface (GUI) on AT-9900 Series Switches

- radio button lists, to choose one of a set of mutually-exclusive options.
- checkboxes, to enable or disable features.

Ports Graphic
Pages on which you can select switch ports use a Ports graphic - a visual representation of the switch ports. To toggle through the selection options, click the icon representing the port you want to select or deselect.

Apply Button
An Apply button applies the configuration settings on the page or the section of the page. The new settings take effect immediately, but are not automatically saved. To save the settings after clicking Apply, click the Save button above the menu.

Cancel Button
A Cancel button closes a popup page without making any changes to the configuration.

Close Button
A Close button closes a popup page, and conserves any changes that you made to the settings on the page by clicking on buttons like Add, Modify, Remove or Apply. Changes you made to editable fields are not conserved when you click Close (unless you first clicked Apply).

The Management Menu
You can use the GUI to manage the switch itself, including:
- creating user accounts and enabling system security
- creating and editing files
- backing files up to the switch’s Flash memory or to a PC or TFTP server
- restoring the switch’s configuration from backup
- specifying which software and configuration files the switch uses on bootup, and displaying the currently-used files
- enabling software version and feature licences
- upgrading the switch’s software
The Monitoring Menu

When you browse to the GUI, the sidebar menu opens to display the monitoring menu, opened at the System > Status. From this menu, other things you can check include:

- information about the switch’s hardware
- information about Address Resolution Protocol (ARP) entries
- the IP route table
- information about the state of ping polling, including counters
- the log messages that the switch automatically generates. You can also set up filters to determine where messages are saved to and which messages are saved.

The Diagnostics Menu

The GUI’s diagnostics pages enable you to troubleshoot network problems and observe traffic flow, including:

- displaying LACP counters
- displaying STP, MSTP and GARP counters
- displaying the number and type of packets received and transmitted by IP, and discarded by the IP gateway
- displaying the number and type of ICMP and UDP packets received and transmitted
- displaying the number and type of RIP packets received and transmitted; and the octets received and transmitted over each IP route
- displaying the number and type of IPX packets received and transmitted; and the bytes received and transmitted over each IPX route
- displaying the contents of the switch’s file system and how much memory is used and available. You can also delete files
- an interface to the switch’s command line interface, allowing you to enter CLI commands.

Combining GUI and CLI Configuration

You can alternate between the GUI and the CLI without difficulty. Note that GUI pages do not automatically refresh to reflect changes in the CLI configuration; you must reload the relevant page (for example, by clicking the Refresh button on your browser).
Troubleshooting

The GUI resource file has a name with the .rsc file extension. To check which resource files are on the switch, use the command:

```
show file
```

To see which GUI resource file the switch is currently using, and which it will use on bootup, use the command:

```
show install
```

To display information about the GUI resource file that is currently installed, use the command:

```
show gui
```

In particular, this command lets you check the file’s validity. If the file is invalid or damaged, download a new file.

To display information about the switch’s HTTP server, use the commands:

```
show http server
show http server session
```

Enabling and Disabling the GUI

The GUI is enabled by default. To enable or disable the GUI, use the following commands:

```
enable gui
disable gui
```

When enabled, the GUI works when a valid resource file for the hardware model is present in flash memory and when the HTTP server is enabled (see “Using HTTP” on page 5-9).

Deleting Temporary Files

Browsers store local copies of web pages as temporary files. If you upgrade to a new GUI resource file, or if you encounter problems in browsing to the GUI, you may need to delete these files (clear the cache). To clear the cache in Internet Explorer:

1. From the Tools menu, select Internet Options.
2. On the General tab, click the Delete Files button.
3. The Delete Files dialog box opens. Click the OK button.

To clear the cache in Netscape 6.2.x:

1. From the Edit menu, select Preferences.
2. Click the Advanced menu option to expand it.
3. Select the Cache menu option.
4. Click the Clear Memory Cache and Clear Disk Cache buttons.
Accessing the Switch via the GUI

Problem  You cannot browse to the switch.

Diagnosis  Check if you can ping the switch’s interface from your PC. If you get a response, this indicates that the interface’s IP address is valid, and that your PC has a route to it.

Solution  ■ If you cannot ping the switch’s interface:

- check that your PC’s gateway is correct, so that your PC has a route to the switch.
- the IP address of the switch’s interface may be incorrect. To correct this, access the CLI and use the `ipaddress` parameter of `set ip interface` command.
- the IP address of the switch’s default gateway may be incorrect, so that the switch does not have a route back to your PC’s gateway. To correct this, access the CLI and use the `nexthop` parameter of the `add ip route` or `set ip route` command.

■ If the switch should be dynamically assigned an IP address, check that the DHCP server can reach the switch, by pinging the switch from the DHCP server.

■ If your PC accesses the Internet through a proxy server, you may need to set your browser to bypass the proxy when browsing to the switch’s IP address range. See “HTTP Proxy Servers” on page 3-4 for more information.

■ If you cannot access the GUI because your username or password fails, check that you are spelling them correctly. The username “manager” is always valid. Its default password is “friend”. Note that passwords are case sensitive.

Problem  The GUI is behaving inconsistently, or you cannot access some pages.

Solution  ■ Delete your browser’s temporary files (see “Deleting Temporary Files” on page 3-15) and try again.

■ Check that JavaScript is enabled.

■ If you are using a toolbar or plug-in on your browser to block pop-ups, disable it while using the GUI. The GUI displays detailed configuration options and information in pop-up windows.

Either turn the toolbar off or specify that pop-ups are allowed for the IP address of the switch. To turn off a toolbar on Internet Explorer 6, select Toolbars from the View menu and make sure the toolbar is not checked.

■ Check that you are trying to access the GUI from a supported operating system and browser combination. See “Browser and PC Setup” on page 3-3 for more information.
Problem  The GUI does not seem to configure the switch correctly.

Solution  ■ Use the buttons on the GUI pages to navigate, not your browser’s Back, Forward or Refresh buttons. The GUI’s navigation buttons perform aspects of the configuration.
■ If you are using a toolbar or plug-in on your browser to block pop-ups, disable it while using the GUI. The GUI displays detailed configuration options and information in pop-up windows.

Either turn the toolbar off or specify that pop-ups are allowed for the IP address of the switch. To turn off a toolbar on Internet Explorer 6, select Toolbars from the View menu and make sure the toolbar is not checked.

Configuring the Switch using the GUI

The AT-9900s switch can be configured and managed through the ETH0 management port by using the HTTP-based Graphical User Interface (GUI). The GUI may be accessed with Internet Explorer version 5 or greater, Netscape 6.2.2 or Netscape 6.2.3. JavaScript must be enabled.

To ensure that configuration settings are saved correctly, use the menus and buttons on the GUI pages to navigate, not the browser buttons.

The management port has a default IP address of 192.168.242.242 and mask of 255.255.255.0. You can change this default before or after you first access the GUI.

Important  If another device on your network already uses 192.168.242.242, first change the address of the management port on the switch by using the CLI before connecting it to the network.

Using the Default IP Address

To access the GUI using the default IP address
1. Plug a PC or laptop into the ETH0 management port.
2. Assign the PC an IP address in the 192.168.242.0 subnet.
3. If you access the Internet through a proxy server, set your browser to bypass the proxy for 192.168.242.242.
5. At the login prompt, enter the user name and password.

User Name: manager
Password: friend

The system status page is displayed. Use the sidebar menu to select options to configure and manage the switch.
Do not leave the ETH0 management port set to the default because this may constitute a serious security risk.
To change the password, select Management > Users from the sidebar menu. Select the Manager account and click Modify.
To change the management port’s IP address, select Configuration > System > Management from the sidebar menu.
To access the GUI’s context-sensitive help system, click the Help button above the sidebar menu or on the page where you want help.
Changing the IP address

Instead of using the default IP address to access the GUI, you can change the address from the command line and use the new address.

To access the GUI using a non-default IP address

1. Access the CLI.
   See the switch’s Installation and Safety Guide for more information.
2. Enable IP by using the command:
   ```
   enable ip
   ```
3. Assign the management port an IP address in the desired subnet by using the command:
   ```
   set ip interface=eth0 ip=ipaddress mask=mask
   ```
4. If the PC from which you access the GUI is on a subnet different from the switch, add a route from the PC to the switch by using the command:
   ```
   add ip route=PC-ipaddress interface=eth0 nexthop=switch-ipaddress
   ```
5. If you access the Internet through a proxy server, set your browser to bypass the proxy for the management port’s IP address.
6. Point your web browser at the new IP address and enter the user name and password at the login prompt.
   ```
   User Name: manager
   Password: friend
   ```
   The system status page is displayed. Use the sidebar menu to select options to configure and manage the switch.

Do not leave the ETH0 management port set to its default because this may constitute a serious security risk

To change the password, select Management > Users from the sidebar menu. Select the Manager account and click Modify.

To change the management port’s IP address, select Configuration > System > Management from the sidebar menu.

To access the GUI’s context-sensitive help system, click the Help button above the sidebar menu or on the page where you want help.
Command Reference

This section describes the commands available on the switch to support day-to-day operational and management activities.

The shortest valid command is denoted by capital letters in the Syntax section. See “Conventions” on page xlix of About this Software Reference for details of the conventions used to describe command syntax. See Appendix A, Messages for a complete list of messages and their meanings.

disable gui

Syntax

DISABLE GUI

Description

This command disables the web-based graphical user interface. If a GUI is installed, it is enabled by default.

The GUI resource file that the switch is currently set to use can be deleted when the GUI is disabled. GUI resource files have a .rsc extension. Use the show install command and check the "Current Install" section to see which resource file is currently set.

Related Commands

enable gui
reset gui
show gui
show install

enable gui

Syntax

ENABLE GUI

Description

This command enables the web-based graphical user interface. If a GUI is installed, it is enabled by default. Even when enabled, the GUI only works when:

- there is a valid resource file for the hardware model being used.
- the HTTP server is enabled.

Related Commands

disable gui
reset gui
show gui
reset gui

Syntax
RESET GUI

Description
This command is used after a new GUI resource file has been loaded so that the switch reads the updated file without the user rebooting the switch.

Example
To use details from the GUI resource file that has just been loaded onto the switch, use the command:

```
reset gui
```

Related Commands
- disable gui
- enable gui
- load in Chapter 5, Managing Configuration Files and Software Versions
- set install in Chapter 5, Managing Configuration Files and Software Versions
- show gui

show gui

Syntax
SHOW GUI

Description
This command displays information about the GUI status and the GUI resource file. The resource file contains the HTML pages that make up the GUI (Figure 3-9, Table 3-1).

```
GUI Configuration
-------------------
Module Status : Enabled

Resource File
--------------
Name : 9924_291-00_en_d.rsc
Status : Good

Header Info
------------
Type : Device
Model : AT-9924
Gui Builder Version : 3.3
Resource File Format : 1
Language : English
Version : 2.9.1-00
File Creation Date : 14/12/2006
Build Type : CUSTOMER
File Size : 3122687
```
Table 3-1: Parameters in the output of the show gui command

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>Module Status</td>
<td>Whether the GUI is enabled.</td>
</tr>
<tr>
<td>Name</td>
<td>Filename of the GUI resource file.</td>
</tr>
<tr>
<td>Status</td>
<td>State of the resource file; either Good (no errors in the file) or Error. If the state is Error, a line is displayed below the status indicating the nature of the error.</td>
</tr>
<tr>
<td>Type</td>
<td>Type of GUI</td>
</tr>
<tr>
<td>Model</td>
<td>The model the resource file has been produced to run on. Resource files are model-dependent, so this must be the same model as the switch.</td>
</tr>
<tr>
<td>GUI Builder Version</td>
<td>Version of the Allied Telesis GUI creation program that this resource file was built with.</td>
</tr>
<tr>
<td>Language</td>
<td>Language in which the GUI is displayed.</td>
</tr>
<tr>
<td>Version</td>
<td>Version of the GUI</td>
</tr>
<tr>
<td>File Creation Date</td>
<td>Date in day/month/year format when the resource file was created.</td>
</tr>
<tr>
<td>Build Type</td>
<td>The status of this build. “Production” indicates a build that has been released for use.</td>
</tr>
<tr>
<td>File size</td>
<td>Byte size of the resource file.</td>
</tr>
</tbody>
</table>

**Example**
To display information about the GUI, use the command:

```
sh gui
```

**Related Commands**
- `disable gui`
- `enable gui`
- `reset gui`